PAT1020 月饼

PAT1020 月饼

题目

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数NN表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数DD表示市场最大需求量。随后一行给出NN个正数表示每种月饼的库存量(以万吨为单位);最后一行给出NN个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例

1
2
3
3 20
18 15 10
75 72 45

输出样例

1
94.50

思路

月饼最好是用结构体(方便排序),分别输入数据后,优先计算利益最高的月饼,库存不够就依次往后排。
输出格式要会。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
//pat1020
#include <stdio.h>
#include <vector>
#include <algorithm>
using namespace std;
typedef struct
{
double weight;
double money;
double per;
}a;
bool bmp(a x, a y)
{
return x.per > y.per;
}
vector<a> arr;
int main(int argc, char const *argv[])
{
int type, limit;
scanf("%d %d", &type, &limit);
for(int i = 0; i < type; i++)
{
a t;
scanf("%lf", &t.weight);
arr.push_back(t);
}
for(int i = 0; i < type; i++)
{
a t = arr[i];
scanf("%lf", &t.money);
t.per = t.money / t.weight;
arr[i] = t;
}
sort(arr.begin(), arr.end(), bmp);
double result = 0;
for(int i = 0; i < type; i++)
{
if (limit >= arr[i].weight)
{
limit -= arr[i].weight;
result += arr[i].money;
}
else
{
result += arr[i].per * limit;
printf("%0.2lf\n", result);
return 0;
}
}
printf("%0.2lf\n", result);
return 0;
}
文章作者: Shengyaqingfeng
文章链接: https://creazyboyone.github.io/pat1020/
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 Shengyaqingfeng's Blog